Normales Thema Probleme mit Dos-Befehlen "net" und "ping" (Gelesen: 4.827 mal)
Peter_K.



Probleme mit Dos-Befehlen "net" und "ping"
21.02.12 um 12:17:05
Beitrag drucken Beitrag drucken  
Für die Netzwerkanmeldung benutze ich ein DOS-Progrämmchen mit dem ich per "ping" zuerst prüfe ob die Server ansprechbar sind, und mappe dann per "net use ..." meine Netzlaufwerke. Bis vor einigen Tagen ging das super. Nur seitdem ich testweise ein Tool für unsere Telefonanlage installiert und wieder deinstalliert habe, gibt es Probleme:

Die Befehle "ping" und "net" (evtl. noch andere, ?) sind nur noch ausführbar wenn ich sie direkt aus dem Windows\System32 Verzeichnis aufrufe wo diese Files auch abgespeichert sind. Rufe ich sie in der DOS-Box auf (ich bin dann ja im Verzeichnis C:\Dokumente und Einstellungen\Username\) bekomme ich die Fehlermeldung (sinngemäß): Das der Befehl entweder falsch geschrieben ist oder die Datei nicht gefunden wurde.

Ich vermute nun das mir durch dieses Telefonanlagentools irgendwas im System zerschossen wurde. Fehlt evtl. jetzt ein Eintrag in den Umgebungsvariablen?

Wer kann mir Tipps geben was da nun faul ist?

Zusatz-Infos:
Kopiere ich das Batch-File in Windows\system32 dann funktioniert alles. Gut könnte ich so lassen, aber Sinn der Sache ist es ja nicht.
  
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.248
Re: Probleme mit Dos-Befehlen "net" und "ping"
Antwort #1 - 21.02.12 um 13:58:59
Beitrag drucken Beitrag drucken  
Vermutlich ist der Suchpfad verlorengegangen. Den effektiv wirksamen Pfad kannst Du in der Textkonsole mit dem Befehl PATH anzeigen lassen. Hier sollten die Verzeichisse C:\Windows sowie C:\Windows\System32 aufgeführt sein, und zwar ziemlich am Anfang.

Abhilfe: Befehle mit voll qualifiziertem Pfad aufrufen, also beispielsweise anstelle von Ping dann C:\Windows\System32\Ping verwenden.
Oder:
Erweitern des Suchpfades. Soll er nur für's aktuelle Environment gültig sein einfach mit dem PATH Befehl selbst - beim Beenden der Shell wird so aber jegliche Änderung wieder verworfen, bzw. dauerhaft über das GUI mit Rechtsklick auf Arbeitsplatz / Eigenschaften / Erweitert / Umgebungsvariablen.
"Benutzervariablen" legt das Environment für den aktuellen User fest, "Systemvariablen" dagegen global für alle Benutzer.

  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
Peter_K.



Re: Probleme mit Dos-Befehlen "net" und "ping"
Antwort #2 - 21.02.12 um 14:50:56
Beitrag drucken Beitrag drucken  
Ah Super!
Das wars... als Path war als erster Eintrag der Installationspfad von dem Telefon-Tool drin:
C:\Programme\PC Connectivity Solution\
%SystemRoot%\system32
%SystemRoot%
%SystemRoot%\System32\Wbem
......


Den habe ich nun gelöscht und nun gehts wieder.
DANKE!

Seltsamerweise wird mir nun, wenn ich die Path-Einträge ansehe (egal ob im DOS-Fenster "Path" oder unter Eigenschaften des Arbeitsplatz), nicht mehr %systemRoot% usw. angezeigt , sondern "C:\Windows\....". Ich habe diese Einträge aber nicht geändert. Komisch...

Aber. Wenn nun wieder alles funktioniert, solls mir egal sein...

Nochmal DANKE!
  
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.248
Re: Probleme mit Dos-Befehlen "net" und "ping"
Antwort #3 - 21.02.12 um 19:43:46
Beitrag drucken Beitrag drucken  
SystemRoot ist ebenfalls eine Umgebungsvariable und zwar eine, die automatisch vom OS gesetzt wird. Rufe einfach mal den Befehl SET in der Konsole auf, dann bekommst Du alle mit aktuellem Inhalt aufgelistet.
In %-Zeichen eingerahmt werden sie bei Verwendung zu ihrem Inhalt (hier: C:\Windows) expandiert.

  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
 
  « Übersicht ‹ Forum Nach oben