Seitenindex umschalten Seiten: 1 2 3 [4] 5  Thema versenden Thema versenden Drucken Drucken
Sehr heißes Thema (mehr als 25 Antworten) VMware Server auf Windows 2000 Prof. (Gelesen: 36.208 mal)
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #45 - 12.05.07 um 16:57:04
Beitrag drucken Beitrag drucken  
Quote:
Sind das Textdateien oder Binärdaten? Wahrscheinlich wohl eher binär bei der Größe, bis auf die letzte...
Ja, bis auf die letzte sind das Binärdaten.

Quote:
Wieso hast Du da denn 3 Millionen .VMDKs?
Die sind durch das Importieren entstanden. Bei Vista habe ich nur eine.

Quote:
daß ich das wunderbare Textkonsolen-Tool vmware-mount.exe benutzen kann um VM-Platten im Host zu mounten.
Wie, wo, was? Habe ich ein Kapitel verpaßt?
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.148
Re: VMware Server auf Windows 2000 Prof.
Antwort #46 - 12.05.07 um 20:04:37
Beitrag drucken Beitrag drucken  
Quote:
Wie, wo, was? Habe ich ein Kapitel verpaßt?
Nein, zumindest keins was ich niedergeschrieben hätte. Das kann man sich in der Konsole leicht selbst schreiben lassen mit vmware-mount.exe /?.
Es ist aber ein zentraler Aspekt bei meinem derzeitigen Projekt mit einer Ubuntu-Surfstation in der VM.
  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #47 - 13.05.07 um 17:19:00
Beitrag drucken Beitrag drucken  
Hi cdk,
erst mal wünsche ich Dir viel Erfolg bei Deinem Linux-Projekt!
Quote:
vmware-mount.exe /?.
Habe ich mir angeschaut, aber beantwortet nicht meine Fragen und ausprobieren möchte ich das im Moment nicht. Ich poste gleich dazu bei der FAQ und hoffe, daß das o.k. ist.

Habe gerade zig Probleme, bei denen ich Schwierigkeiten habe sie verständlich zu schildern. Ich fange mal mit meinem Host an.

Das "Mauszittern" in der Vista-VM hatte ich ja schon erwähnt. Jetzt fängt das auch auf dem Host an. Nicht so schlimm wie da, aber speziell im Mozilla verhält sich die Mausanzeige nicht mehr korrekt. Wenn ich auf einen Link gehe, zittert der Mauspfeil kurz und wandelt sich nicht mehr in das Handsymbol um. Anklicken kann ich den Link aber. Nach Host Neustart war alles wieder gut. Heute ist es noch nicht aufgetaucht.

Wenn ich VPC ins Internet lassen will (wollte da gestern vor dem Umzug in VMware eigentlich noch was erledigen) muß ich bei der Host-LAN-Verbindung "Virtual Machine Network Services" aktivieren. Dann kommt aber jetzt der Host nicht mehr ins Internet. Da will ich aber jetzt nicht weiter suchen, weil ich VPC deinstallieren werde, sobald ich es nicht mehr für meine ungelösten VM-Pläne (dazu melde ich mich später) brauche.

Meine Festplatte und die USB-Platte sind fast voll. Ich muß erst mal Platz schaffen. 2. Festplatte, ich weiß wohl, aber das verschiebe ich noch....
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.148
Re: VMware Server auf Windows 2000 Prof.
Antwort #48 - 13.05.07 um 17:37:10
Beitrag drucken Beitrag drucken  
Quote:
Das "Mauszittern" in der Vista-VM hatte ich ja schon erwähnt. Jetzt fängt das auch auf dem Host an.
Kann ich mir nichts drunter vorstellen. Aber wenn das ohne VM (-Dienste) auch auf dem Host der Fall ist, dann ist's wohl kein VM-Problem...
  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #49 - 13.05.07 um 19:27:28
Beitrag drucken Beitrag drucken  
Quote:
Aber wenn das ohne VM (-Dienste) auch auf dem Host der Fall ist
Weiß ich jetzt nicht mehr ob die VM-Dienste da noch liefen (derzeit beende ich die noch manuell). Wenn das Problem wieder auftritt versuche ich es einzukreisen.

Meine VPC-Dateien sind jetzt nach VMware umgezogen, aber zufrieden bin ich damit noch nicht. Meinen W98-Guest konnte ich nicht mit VMware importieren, darum habe ich mir noch mal den VMware-Converter angesehen. Damit hat es dann geklappt und dabei ist mir das aufgefallen:

http://www.monirapunzel.de/bilder/vm_converter.jpg

Ich vermute VMware macht automatisch "linked clone" und VMware-Converter kann "linked clone" und "full clone".
Das wäre dann die Erklärung für meine vielen VMDK-Dateien. Die "wachsen" jetzt und das gefällt mir nicht. Eine Datei mit fester Größe finde ich schon allein für die Übersichtlichkeit besser. Dann muß ich wohl doch mit Images arbeiten oder meine alten Guests neu erstellen. Keine Ahnung warum der VMware-Converter mit meinen W2k- und XP-Guests nicht umgehen kann.

Ansonsten zickt jeder Guest (außer Vista) bei irgendwas rum, wird wohl dauern bis ich die alle im Griff habe.....
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.148
Re: VMware Server auf Windows 2000 Prof.
Antwort #50 - 13.05.07 um 21:25:43
Beitrag drucken Beitrag drucken  
Dein Screenshot in #43 zeigt auf jeden Fall einen Linked Clone. Die einzige Datei mit Festplattengröße ist da ja schließlich die VHD.
  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #51 - 13.05.07 um 22:46:18
Beitrag drucken Beitrag drucken  
Ja. Ein Linked Clone ist nichts für mich. Muß wohl so ähnlich sein wie Du in der FAQ bei den Snapshots beschrieben hast. Das Verzeichnis vom Screenshot in #43 hat inzwischen ca. 700 MB mehr, insgesamt über 9 GB und ich kann die VM nicht mehr starten. "Betriebssystem fehlt". TI hat mal wieder versagt.....
Naja, Versuch macht klug.

Korrektur! Ich hatte diese VM noch nicht beendet. Die hat jetzt über 15 GB.
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #52 - 14.05.07 um 12:24:34
Beitrag drucken Beitrag drucken  
O.T. 1.
Das "Mausproblem" wurde durch diese Seite verursacht
https://www.victorinox.ch/
Da funktioniert meine Maus nicht mehr korrekt und das ist dann auch auf anderen Seiten bis ich den Mozilla neu starte.

O.T. 2.
Mein Host-Rechner scheint grundsätzlich Image-Probleme zu haben, die auch in der VM auftreten.
Quote:
TI hat mal wieder versagt.....
Das Archiv war beim Überprüfen in Ordnung und kurz vor Wiederherstellung kam die Meldung "Archiv beschädigt."
Mit demselben Archiv konnte ich an einem anderen Host-Rechner eine neue VM durch Imagewiederherstellung erstellen.

  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
jmk
God Member
*****
Offline


Beiträge: 2.741
Standort: Hennef
Re: VMware Server auf Windows 2000 Prof.
Antwort #53 - 15.05.07 um 03:58:27
Beitrag drucken Beitrag drucken  
entschuldigt die unterbrechung. Zwinkernd

habe mich gerade mehr oder weniger erfolgreich durch diesen mörder-Thread gekämpft. Was haltet ihr davon, wenn ihr bei VMware in die Entwicklung geht. Dann werdet ihr dafür wenigstens anständig bezahlt. Zwinkernd
Nee, ist schon ganz nett, was ihr hier alles zusammengeschrieben habt.

Mich würde aber noch interessieren, wie das mit dem mounten von VMDKs funktioniert. Werden die dir dann als Laufwerk in das Dateisystem eingehängt? Und kannst du dann unabhängig vom Dateisystem auf die Daten zugreifen? Werden dir zB die Zugriffsrechte bei NTFS angezeigt? Und wie läuft das mit unixoiden Dateisystemen? Du verwendest ext3 unter Ubuntu? Übersetzt dir das Tool dann die Rechte auf irgendeine Art und Weise in die Windowswelt oder werden die Rechte einfach ignoriert?

zu Monikas OT1:
Die Site funktioniert wunderbar, bei mir. Zwinkernd Ich hoffe, dein Mozila ist auf dem neuesten Stand. Außerdem schadet es bestimmt nicht mal im Task-Manager nach ungewöhnlichen Systembelastungen durch verschiedene Dienste zu schauen.

OT2:
Wenn ich das richtig verstehe, hast du eine Hand voll Images und die würdest du gerne in je eine VM einspielen? Oder möchtest du ein Image auf dem Host wiederherstellen? Ersteres doch ganz sicher, oder!?
  

Zum Seitenanfang
ICQ ICQ  
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.148
Re: VMware Server auf Windows 2000 Prof.
Antwort #54 - 15.05.07 um 12:43:02
Beitrag drucken Beitrag drucken  
Quote:
Mich würde aber noch interessieren, wie das mit dem mounten von VMDKs funktioniert.
Falls Du von dem Mount-Tool für den Host redest - ganz einfach Laut lachend. Bsp.:
Code
Alles auswählen
@if exist v:\nul goto weiter

vmware-mount.exe v: "Z:\My Virtual Machines\Fileshare.vmdk"
if not errorlevel 1 goto end
@echo "Mount VM-Disk" fehlgeschlagen! Virtuelles Laufwerk im Host nicht verfuegbar.

:weiter
.....

:end 



Dieses Tool bietet dem Host schlichtweg eine oder mehrere Partitionen an und führt ein Mapping auf einen Laufwerksbuchstaben durch.
Was der Host mit dem Laufwerk macht hängt vom OS bzw. seinen Treibern ab. Bei FAT und NTFS ist's ja keine Frage, bei EXT3 kommt's darauf an ob und wie der Windows-Treiber die Rechteverwaltung umsetzt.
Ausprobiert habe ich letzteres aber noch nicht - muß ja auch nicht sein daß ich meinem stabilen Host aus Jux und Tollerei irgendwelche Alpha-Treiber unterjubele.
In praktischer Benutzung habe ich eine FAT32-Partition auf welcher ich Mails, Bookmarks und testweise auch die Profile von Firefox und Thunderbird ablege, damit mir diese Resourcen in beiden Welten zur Verfügung stehen.
  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
jmk
God Member
*****
Offline


Beiträge: 2.741
Standort: Hennef
Re: VMware Server auf Windows 2000 Prof.
Antwort #55 - 15.05.07 um 17:28:25
Beitrag drucken Beitrag drucken  
hey, erst von ext3 zu reden und dann von Alpha-Treibern, ist jawohl Majestätsbeleidigung!  Schockiert/Erstaunt Ärgerlich Laut lachend
hier gibt es im Übrigen einen ext2- Treiber für Windows:
http://www.fs-driver.org/faq.html
(Ext3 = Ext2+Journaling, deswegen ist dieser ext2-Treiber voll kompatibel)
  

Zum Seitenanfang
ICQ ICQ  
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #56 - 15.05.07 um 21:00:45
Beitrag drucken Beitrag drucken  
@ jmk

Schön, daß Du reinschaust.  Zwinkernd
Quote:
zu Monikas OT1:
Die Site funktioniert wunderbar, bei mir. Zwinkernd Ich hoffe, dein Mozila ist auf dem neuesten Stand. Außerdem schadet es bestimmt nicht mal im Task-Manager nach ungewöhnlichen Systembelastungen durch verschiedene Dienste zu schauen.
Ich habe Mozilla 1.7.13 und hatte den Task-Manager überprüft. Ich verdächtige die o. g. Seite, weil ich an einem anderen Rechner dasselbe Problem hatte, nachdem ich da auch diese Seite aufgerufen hatte. Im IE und FF funktioniert die bei mir auch normal. Im Mozilla funktioniert die nur wenn ich JavaScript deaktiviere.

Quote:
OT2:
Wenn ich das richtig verstehe, hast du eine Hand voll Images und die würdest du gerne in je eine VM einspielen? Oder möchtest du ein Image auf dem Host wiederherstellen? Ersteres doch ganz sicher, oder!?
Ja, ersteres. Da ich immer noch nicht klar komme, versuche ich die Lage mal eindeutig zu schildern, um selber noch durchzublicken.

Es geht um 2 W2k-Rechner: Monika-Host und Rapunzel-Host. Der Monika-Host hat schon immer Image-Probleme. DriveImage läuft da nicht (gibt es einen alten ellenlangen Thread) und TrueImage läuft da nicht zuverlässig (gibt es mehrere alte Threads). Irgendwann muß ich den Monika-Host mal neu installieren...
DI und TI laufen auf dem Rapunzel-Host. Also kann ich davon ausgehen, daß ich keine Bedienerfehler mache.

Momentan erstelle ich auf dem Monika-Host VMs. (Genug RAM habe ich inzwischen.)VMs mit neuinstallierten Betriebssystemen laufen, da habe ich jetzt W2k, XP und Vista.
Umzug meiner alten W98/Wk2-VPCs habe ich mit VMware Server bzw. VMware Converter versucht, das ergibt aber nur "Linked Clones" und die gefallen mir nicht. Den W98 werde ich "neu machen", die anderen beiden will ich mir über Image (inkl. c't Impfkur) holen.
Von dem Monika-Host habe ich mit TI ein (altes) Image in eine VM gebracht und die läuft.
Seit Tagen versuche ich mit mehreren Images (inkl. c't Impfkur) von dem Rapunzel-Host eine VM auf dem Monika-Host zu erstellen. DI und TI brechen immer ab. Darum habe ich auf dem Rapunzel-Host auch VMware installiert und da das Rapunzel-Image in eine VM gespielt. Ging nicht mit DI, hat aber mit TI geklappt.
Die "VMDK" war dann zu groß um sie auf dem Rapunzel-Host zu brennen, darum habe ich der Rapunzel-VM eine 2. Platte dran gehängt und darauf mit TI ein Image gemacht. Dieses "Rapunzel-VM-Image" habe ich mit dann mit der vmware-mount.exe auf den Rapunzel-Host kopiert und dann gebrannt. Das will ich jetzt auf dem Monika-Host in eine neue VM spielen.

und nu hängt der Monika-Host und ich muß erst mal neu starten

Rest später



Edit: Tippfehler korrigiert.
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
Monika
God Member
*****
Offline


Beiträge: 5.928
Re: VMware Server auf Windows 2000 Prof.
Antwort #57 - 15.05.07 um 22:08:49
Beitrag drucken Beitrag drucken  
Mein WindowsExplorer hatte sich aufgehangen....

Quote:
Das will ich jetzt auf dem Monika-Host in eine neue VM spielen.
Hat mit TI jetzt endlich funktioniert!

Aber ich kapiere das nicht. Bei beiden Hosts habe ich die neuen VMs mit TI-Boot-CD gestartet. Die Rapunzel-VM hatte eine leere Platte, TI hatte Zugriff auf CD/ISO und die "Wiederherstellung" klappte sofort. Bei der Monika-VM hatte TI bei leerer Platte keinen Zugriff auf CD/ISO. Das ging erst nachdem ich die Monika-VM mit einer W98-Startdiskette partitioniert und formatiert habe. Egal, läuft ja jetzt.


@ cdk

Gibt es eigentlich einen "Trick" um an die Bootreihenfolge in der VM zu kommen? Der ist meistens schneller als ich ESC drücken kann.

Bei den Monika-VMs klappte die Installation der VMware Tools sofort. Bei der Rapunzel-VM tat sich nichts. Nach zig Versuchen fiel mir ein, daß wir mal an anderer Stelle drüber gesprochen hatten.

cdk schrieb on 11.09.06 um 20:35:39:
Virtual Machine Additions:
Nun kenne ich VPC nicht, aber bei VMware gibt's was ähnliches und ich habe einen ganzen Abend lang rumexperimentiert bis es geklappt hat. VMware macht das mit einem "geheimen" eingebauten ISO, von welchen aus diese speziellen Tools installiert werden - das wußte ich zu diesem Zeitpunkt aber noch nicht.
Jedenfalls hatte ich die Installation von der VMware-Shell aus losgeklickt aber passiert ist bis in alle Ewigkeit nichts.
Wie sich dann herausstellte war das einzige Problem daß ich bei jeder Windows-Installation das CD-Autoplay abstelle. Also hat mein Start der Installation das geheime ISO ins virtuelle CD-ROM eingelegt und Punkt. Mangels CD-Autostart ist die Installation kommentarlos nicht gestartet.
Die Lösung war einfach. Ich mußte lediglich in der VM das CD-Laufwerk im Total Commmander (oder Explorer) öffnen - dort präsentierte sich der Inhalt des ISOs und dort konnte ich manuell die SETUP.EXE doppelklicken. Das war alles. Alternativ hätte ich natürlich auch das CD-Autoplay wieder aktivieren können.

Hat dann auch so geklappt.

vmware-mount.exe
Wie hängst Du dieses virtuelle Laufwerk wieder ab? Bei /d sagt er ich muß /f nehmen. Dann sieht es in der Textkonsole so aus als wenn er fertig ist. Die zugehörige VM kann ich dann aber nicht starten. Da kommt eine Fehlermeldung geschlossen oder so ähnlich.
  

Grüße von Monika
Zum Seitenanfang
 
IP gespeichert
 
cdk
Global Moderator
*****
Offline


Beiträge: 10.148
Re: VMware Server auf Windows 2000 Prof.
Antwort #58 - 16.05.07 um 00:37:05
Beitrag drucken Beitrag drucken  
Quote:
Bei /d sagt er ich muß /f nehmen.
Wenn er das sagt ist noch ein Zugriff auf dieses Laufwerk geöffnet und man sollte sich gut überlegen welcher das ist. Mit /f wird der dann nämlich gekillt.

Quote:
Die zugehörige VM kann ich dann aber nicht starten.
Das soll so sein und ist beabsichtigt.
  

Grütze, cdk

Wer Bier liebt liebt auch CO²
Zum Seitenanfang
 
IP gespeichert
 
jmk
God Member
*****
Offline


Beiträge: 2.741
Standort: Hennef
Re: VMware Server auf Windows 2000 Prof.
Antwort #59 - 16.05.07 um 02:21:38
Beitrag drucken Beitrag drucken  
zu den Imageproblemen kann ich erstmal nur sagen, dass ich mir zwar gerade deien Text reingezogen habe mir zu dieser Stunde aber doch die Motivation fehlt, die 37 Probleme welche du da kunterbund beschreibst alle auseinanderzuhalten.

Erstmal ein paar gezielte Rückfragen:
Du schreibst, du TI und DI würden auf dem einen realen Rechner nicht laufen. Was bedeutet das? Die Windowsprogramme laufen nicht richtig oder ist auch das booten der CDds/Floppys, welche die Bachuptools unter DOS laufen lassen, nicht möglich?
Bei Problemen würde ich generell erstmal die Windowstools vergessen und nur mit den Bootmedien arbeiten.

Zweitens würde mich interessieren woran exakt das zurückspielen der Images scheitert. Ich nehme mal an, dass du in der VM versuchst ein Disk/Floppy mit DOS+TI/DI zu booten und damit das Image zurückzuspielen. Scheitert bereits der Start dieser Tools? Brechen die Tools ihre Jobs mit einem Fehler ab? Oder funktioniert das zurückgespielte Image nach dem Wiederherstellungsprozess nicht?
Beantworte diese Fragen erstmal nur für eines der Images und nicht direkt für das ganze Dutzend. Zwinkernd

zu den Linked Clones:
Wieso erstellst du überhaupt solche "Linked Clones"? Du kannst im VMware Converter doch auch einstellen, dass du ein "full clone" haben möchtest, wie ich es aus Antwort 49 entnehme. Es ist sicherlich auch günstiger einer virtuellen Disk 100% ihres maximalen Speichers direkt zuzuweisen, anstatt das File langsam wachsen zu lassen. (Vorausgesetzt, mann hat den nötigen Speicher dazu.)
  

Zum Seitenanfang
ICQ ICQ  
IP gespeichert
 
Seitenindex umschalten Seiten: 1 2 3 [4] 5 
Thema versenden Thema versenden Drucken Drucken
 
  « Übersicht ‹ Forum Nach oben